const regex = /\b(\d+)\s*[Ss][Ff]\b/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(\\d+)\\s*[Ss][Ff]\\b', 'g')
const str = `'other stuff 1000 SF'
'other stuff 1000SF'
a b c 5sf 10sf 12sf
aa 00 1100 fs sf 1sf
1sf.
.1sf?
5sff`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}