import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(\\d+)\\s*[Ss][Ff]\\b";
final String string = "'other stuff 1000 SF'\n"
+ "'other stuff 1000SF'\n"
+ "a b c 5sf 10sf 12sf\n"
+ "aa 00 1100 fs sf 1sf\n"
+ "1sf.\n"
+ ".1sf?\n"
+ "5sff";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}