use strict;
my $str = '\'word1 \'word2 word3\'
\'axxx\' \'bx bxxxxx\'';
my $regex = qr/('[^']+')$/mp;
my $subst = '$1 $1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";