using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(?:2\d(?:1[4-9]|[2-9]\d)|\d{5,}|[3-9]\d{3,})\b";
string input = @"1999 1985 2013 2014 2007 2016 2050 18075 12370 2199 2267 9999 3000 4000 4211";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}