const regex = /\b(?:2\d(?:1[4-9]|[2-9]\d)|\d{5,}|[3-9]\d{3,})\b/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(?:2\\d(?:1[4-9]|[2-9]\\d)|\\d{5,}|[3-9]\\d{3,})\\b', 'g')
const str = `1999 1985 2013 2014 2007 2016 2050 18075 12370 2199 2267 9999 3000 4000 4211`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}