$re = '/\b(?:2\d(?:1[4-9]|[2-9]\d)|\d{5,}|[3-9]\d{3,})\b/';
$str = '1999 1985 2013 2014 2007 2016 2050 18075 12370 2199 2267 9999 3000 4000 4211';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);