// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\b(?:2\d(?:1[4-9]|[2-9]\d)|\d{5,}|[3-9]\d{3,})\b").unwrap();
let string = "1999 1985 2013 2014 2007 2016 2050 18075 12370 2199 2267 9999 3000 4000 4211";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}