re = /(\d{3})(\d{3})(\d{3})(\d{2})/
str = '09551130401'
subst = '$1.$2.$3-$4'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result