// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(\d{3})(\d{3})(\d{3})(\d{2})").unwrap();
let string = "09551130401";
let substitution = "$1.$2.$3-$4";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}