package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(sin|cos|tan|\d+(?:\.\d+)?|[-()+*/%])`)
var str = `20.55 * 0.5 * cos(360) + sin 0 * cos 90 + 1 * sin (180 + 90) * 0`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}