use strict;
my $str = '20.55 * 0.5 * cos(360) + sin 0 * cos 90 + 1 * sin (180 + 90) * 0';
my $regex = qr~(sin|cos|tan|\d+(?:\.\d+)?|[-()+*/%])~p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}