$re = '~(sin|cos|tan|\d+(?:\.\d+)?|[-()+*/%])~';
$str = '20.55 * 0.5 * cos(360) + sin 0 * cos 90 + 1 * sin (180 + 90) * 0';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);