#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:[^{}]*|\t{1,4}[{}])$"
Local $sString = " Menu "MenuName"" & @CRLF & _
" {" & @CRLF & _
" Menu "SubMenuName"" & @CRLF & _
" {" & @CRLF & _
" Option "OptionName" "Command"" & @CRLF & _
" Option "OptionName" "Command"" & @CRLF & _
" }" & @CRLF & _
" }" & @CRLF & _
"// This is a comment line" & @CRLF & _
"// [ curly brackets in comment lines are made square so they don't get counted as balancing" & @CRLF & _
"" & @CRLF & _
" Menu "MenuName"{" & @CRLF & _
" Menu "SubMenuName"" & @CRLF & _
" {" & @CRLF & _
" Option "OptionName" "Command"" & @CRLF & _
" Option "OptionName" "Command" }" & @CRLF & _
" }"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")