re = /^(?:[^{}]*|\t{1,4}[{}])$/m
str = ' Menu "MenuName"
{
Menu "SubMenuName"
{
Option "OptionName" "Command"
Option "OptionName" "Command"
}
}
// This is a comment line
// [ curly brackets in comment lines are made square so they don\'t get counted as balancing
Menu "MenuName"{
Menu "SubMenuName"
{
Option "OptionName" "Command"
Option "OptionName" "Command" }
}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end