using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:[^{}]*|\t{1,4}[{}])$";
string input = @" Menu ""MenuName""
{
Menu ""SubMenuName""
{
Option ""OptionName"" ""Command""
Option ""OptionName"" ""Command""
}
}
// This is a comment line
// [ curly brackets in comment lines are made square so they don't get counted as balancing
Menu ""MenuName""{
Menu ""SubMenuName""
{
Option ""OptionName"" ""Command""
Option ""OptionName"" ""Command"" }
}";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}