use strict;
my $str = ' Menu "MenuName"
{
Menu "SubMenuName"
{
Option "OptionName" "Command"
Option "OptionName" "Command"
}
}
// This is a comment line
// [ curly brackets in comment lines are made square so they don\'t get counted as balancing
Menu "MenuName"{
Menu "SubMenuName"
{
Option "OptionName" "Command"
Option "OptionName" "Command" }
}';
my $regex = qr/^(?:[^{}]*|\t{1,4}[{}])$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}