// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:[^{}]*|\t{1,4}[{}])$").unwrap();
let string = " Menu \"MenuName\"
{
Menu \"SubMenuName\"
{
Option \"OptionName\" \"Command\"
Option \"OptionName\" \"Command\"
}
}
// This is a comment line
// [ curly brackets in comment lines are made square so they don't get counted as balancing
Menu \"MenuName\"{
Menu \"SubMenuName\"
{
Option \"OptionName\" \"Command\"
Option \"OptionName\" \"Command\" }
}";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}