#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "([^\r\n]*[\r\n]+)[^\r\n]*[\r\n]*"
Local $sString = "foo" & @CRLF & _
"bar" & @CRLF & _
"test" & @CRLF & _
"123"
Local $sSubst = "\1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)