$re = '/([^\r\n]*[\r\n]+)[^\r\n]*[\r\n]*/';
$str = 'foo
bar
test
123';
$subst = "\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;