package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([^\r\n]*[\r\n]+)[^\r\n]*[\r\n]*`)
var str = `foo
bar
test
123`
var substitution = "\1"
fmt.Println(re.ReplaceAllString(str, substitution))
}