use strict;
my $str = 'foo
bar
test
123';
my $regex = qr/([^\r\n]*[\r\n]+)[^\r\n]*[\r\n]*/p;
my $subst = '\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";