re = /([^\r\n]*[\r\n]+)[^\r\n]*[\r\n]*/
str = 'foo
bar
test
123'
subst = '\\1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result