using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\d\d([-/])\d\d\1\d{4} \d\d:\d\d [AP]M ET$";
string input = @"06-01-2023 11:59 PM ET
06/01/2023 11:59 PM ET";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}