const regex = new RegExp('^\\d\\d([-/])\\d\\d\\1\\d{4} \\d\\d:\\d\\d [AP]M ET$', 'gm')
const str = `06-01-2023 11:59 PM ET
06/01/2023 11:59 PM ET`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}