import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\d\\d([-/])\\d\\d\\1\\d{4} \\d\\d:\\d\\d [AP]M ET$";
final String string = "06-01-2023 11:59 PM ET\n"
+ "06/01/2023 11:59 PM ET";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}