$re = '/^\d\d([-/])\d\d\1\d{4} \d\d:\d\d [AP]M ET$/m';
$str = '06-01-2023 11:59 PM ET
06/01/2023 11:59 PM ET';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);