re = /^\d\d([-\/])\d\d\1\d{4} \d\d:\d\d [AP]M ET$/m
str = '06-01-2023 11:59 PM ET
06/01/2023 11:59 PM ET'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end