using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*[^\s](?<!\b\\n\b)""\s+""[^\s].*";
string input = @"1)
abc def ""ghi jkl""
""mno pqr""
but not 2)
abc def ""ghi jkl ""
""mno pqr""
nor 3)
abc def ""ghi jkl""
"" mno pqr""
nor 4)
abc def ""ghi jkl\n""
""mno pqr
1)
abc def ""ghi jkl/""
""mno pqr""
abc def ""ghi jkl\""
""mno pqr""
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}