const regex = /.*[^\s](?<!\b\\n\b)"\s+"[^\s].*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.*[^\\s](?<!\\b\\\\n\\b)"\\s+"[^\\s].*', 'gm')
const str = `1)
abc def "ghi jkl"
"mno pqr"
but not 2)
abc def "ghi jkl "
"mno pqr"
nor 3)
abc def "ghi jkl"
" mno pqr"
nor 4)
abc def "ghi jkl\\n"
"mno pqr
1)
abc def "ghi jkl/"
"mno pqr"
abc def "ghi jkl\\"
"mno pqr"
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}