$re = '/.*[^\s](?<!\b\\\\n\b)"\s+"[^\s].*/m';
$str = '1)
abc def "ghi jkl"
"mno pqr"
but not 2)
abc def "ghi jkl "
"mno pqr"
nor 3)
abc def "ghi jkl"
" mno pqr"
nor 4)
abc def "ghi jkl\\n"
"mno pqr
1)
abc def "ghi jkl/"
"mno pqr"
abc def "ghi jkl\\"
"mno pqr"
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);