use strict;
my $str = '1)
abc def "ghi jkl"
"mno pqr"
but not 2)
abc def "ghi jkl "
"mno pqr"
nor 3)
abc def "ghi jkl"
" mno pqr"
nor 4)
abc def "ghi jkl\\n"
"mno pqr
1)
abc def "ghi jkl/"
"mno pqr"
abc def "ghi jkl\\"
"mno pqr"
';
my $regex = qr/.*[^\s](?<!\b\\n\b)"\s+"[^\s].*/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}