import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".*[^\\s](?<!\\b\\\\n\\b)\"\\s+\"[^\\s].*";
final String string = "1)\n"
+ "abc def \"ghi jkl\"\n"
+ " \"mno pqr\"\n"
+ "but not 2)\n\n"
+ "abc def \"ghi jkl \"\n"
+ " \"mno pqr\"\n"
+ "nor 3)\n\n"
+ "abc def \"ghi jkl\"\n"
+ " \" mno pqr\"\n"
+ "nor 4)\n\n"
+ "abc def \"ghi jkl\\n\"\n"
+ " \"mno pqr\n\n\n"
+ "1)\n"
+ "abc def \"ghi jkl/\"\n"
+ " \"mno pqr\"\n\n"
+ "abc def \"ghi jkl\\\"\n"
+ " \"mno pqr\"\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}