# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/-{9,}(?:(?!-{9}).)*?- \[\d+]//gm;t' <<< "---------Some text is here.---------More text is here - [3548]----- Even more text is here.-----------More text is here - [408]--------- Even more text is here again.
-----------------------More text; is here - [3548]"