using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"-{9,}(?:(?!-{9}).)*?- \[\d+]";
string substitution = @"";
string input = @"---------Some text is here.---------More text is here - [3548]----- Even more text is here.-----------More text is here - [408]--------- Even more text is here again.
-----------------------More text; is here - [3548]";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}