const regex = /-{9,}(?:(?!-{9}).)*?- \[\d+]/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('-{9,}(?:(?!-{9}).)*?- \\[\\d+]', 'gm')
const str = `---------Some text is here.---------More text is here - [3548]----- Even more text is here.-----------More text is here - [408]--------- Even more text is here again.
-----------------------More text; is here - [3548]`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);