re = /-{9,}(?:(?!-{9}).)*?- \[\d+]/m
str = '---------Some text is here.---------More text is here - [3548]----- Even more text is here.-----------More text is here - [408]--------- Even more text is here again.
-----------------------More text; is here - [3548]'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result