package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?misU)q\w{1,1}e\w{3,3}on$`)
var str = `questionx
questiony
questionza
questionaas
questionbasa
questioncdfd
questionddgf
vkjasdashdjk
SKDJSK
fsfsdf
3lrkdfl
983439
fksds
kjadksajdsjdskd
asmndsamdds
questioncdfdwwewe
question`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}