re = /q\w{1,1}e\w{3,3}on$/mi
str = 'questionx
questiony
questionza
questionaas
questionbasa
questioncdfd
questionddgf
vkjasdashdjk
SKDJSK
fsfsdf
3lrkdfl
983439
fksds
kjadksajdsjdskd
asmndsamdds
questioncdfdwwewe
question'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end