use strict;
my $str = 'questionx
questiony
questionza
questionaas
questionbasa
questioncdfd
questionddgf
vkjasdashdjk
SKDJSK
fsfsdf
3lrkdfl
983439
fksds
kjadksajdsjdskd
asmndsamdds
questioncdfdwwewe
question';
my $regex = qr`q\w{1,1}e\w{3,3}on$`misp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}