// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?misU)q\w{1,1}e\w{3,3}on$").unwrap();
let string = "questionx
questiony
questionza
questionaas
questionbasa
questioncdfd
questionddgf
vkjasdashdjk
SKDJSK
fsfsdf
3lrkdfl
983439
fksds
kjadksajdsjdskd
asmndsamdds
questioncdfdwwewe
question";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}