using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(\d+)(?:(?:[\.\s]0+|(\.\d+)))?\s?USD";
string substitution = @"$\1\2";
string input = @"123.00 USD
1234 USD
357.0 USD
456 00 USD
651USD
753.684 USD
123 456 USD
-123 USD
789.00 XXX
123.00 wrongcurrency
test string
$159";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}