const regex = /\b(\d+)(?:(?:[\.\s]0+|(\.\d+)))?\s?USD/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(\\d+)(?:(?:[\\.\\s]0+|(\\.\\d+)))?\\s?USD', 'g')
const str = `123.00 USD
1234 USD
357.0 USD
456 00 USD
651USD
753.684 USD
123 456 USD
-123 USD
789.00 XXX
123.00 wrongcurrency
test string
\$159`;
const subst = `$\1\2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);