re = /\b(\d+)(?:(?:[\.\s]0+|(\.\d+)))?\s?USD/
str = '123.00 USD
1234 USD
357.0 USD
456 00 USD
651USD
753.684 USD
123 456 USD
-123 USD
789.00 XXX
123.00 wrongcurrency
test string
$159'
subst = '$\\1\\2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result