import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(\\d+)(?:(?:[\\.\\s]0+|(\\.\\d+)))?\\s?USD";
final String string = "123.00 USD\n"
+ "1234 USD\n"
+ "357.0 USD\n"
+ "456 00 USD\n"
+ "651USD\n"
+ "753.684 USD\n"
+ "123 456 USD\n"
+ "-123 USD\n"
+ "789.00 XXX\n"
+ "123.00 wrongcurrency\n"
+ "test string\n"
+ "$159";
final String subst = "$\\1\\2";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}