using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\""(.+?)\"")|(\d+(\.\d*)*)|(\w+)";
string input = @"""je mange, et toi manges-tu ?"", oui, 3.45, ""non""
( ""je mange, et toi manges-tu ?"", oui, 3.45, 6, faux, vrai, ""non"" )
450
45
10
1
1.5
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}