import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\\"(.+?)\\\")|(\\d+(\\.\\d*)*)|(\\w+)";
final String string = "\"je mange, et toi manges-tu ?\", oui, 3.45, \"non\"\n"
+ "( \"je mange, et toi manges-tu ?\", oui, 3.45, 6, faux, vrai, \"non\" )\n"
+ "450\n"
+ "45\n\n"
+ "10\n"
+ "1\n"
+ "1.5\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}