package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\"(.+?)\")|(\d+(\.\d*)*)|(\w+)`)
var str = `"je mange, et toi manges-tu ?", oui, 3.45, "non"
( "je mange, et toi manges-tu ?", oui, 3.45, 6, faux, vrai, "non" )
450
45
10
1
1.5
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}