$re = '/(\"(.+?)\")|(\d+(\.\d*)*)|(\w+)/';
$str = '"je mange, et toi manges-tu ?", oui, 3.45, "non"
( "je mange, et toi manges-tu ?", oui, 3.45, 6, faux, vrai, "non" )
450
45
10
1
1.5
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);