const regex = new RegExp('(\\"(.+?)\\")|(\\d+(\\.\\d*)*)|(\\w+)', 'g')
const str = `"je mange, et toi manges-tu ?", oui, 3.45, "non"
( "je mange, et toi manges-tu ?", oui, 3.45, 6, faux, vrai, "non" )
450
45
10
1
1.5
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}