#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!(\d)\1{10,})(?=.*\d)[A-Za-z0-9]{11}"
Local $sString = "90956780083" & @CRLF & _
"PR213328112" & @CRLF & _
"00000000000" & @CRLF & _
"00000000001" & @CRLF & _
"0000" & @CRLF & _
"123456789" & @CRLF & _
"1234" & @CRLF & _
"abc123" & @CRLF & _
"456456" & @CRLF & _
"987654321" & @CRLF & _
"3210" & @CRLF & _
"çá058" & @CRLF & _
"PR 213328112" & @CRLF & _
"PR.213328112"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")